o
    í6Wj  ã                   @  sR   d dl mZ d dlmZ dgZG dd„ deƒZeD ]Zeeej 	¡ e
eƒƒ qdS )é    )Úannotations)ÚIntEnumÚcodesc                   @  s€  e Zd ZdZdZd[dd	„Zd\d
d„Zed]dd„ƒZed^dd„ƒZed^dd„ƒZ	ed^dd„ƒZ
ed^dd„ƒZed^dd„ƒZed^dd„ƒZdZdZdZdZdZd Zd!Zd"Zd#Zd$Zd%Zd&Zd'Zd(Zd)Zd*Zd+Zd,Zd-Z d.Z!d/Z"d0Z#d1Z$d2Z%d3Z&d4Z'd5Z(d6Z)d7Z*d8Z+d9Z,d:Z-d;Z.d<Z/d=Z0d>Z1d?Z2d@Z3dAZ4dBZ5dCZ6dDZ7dEZ8dFZ9dGZ:dHZ;dIZ<dJZ=dKZ>dLZ?dMZ@dNZAdOZBdPZCdQZDdRZEdSZFdTZGdUZHdVZIdWZJdXZKdYS )_r   aG  HTTP status codes and reason phrases

    Status codes from the following RFCs are all observed:

        * RFC 7231: Hypertext Transfer Protocol (HTTP/1.1), obsoletes 2616
        * RFC 6585: Additional HTTP Status Codes
        * RFC 3229: Delta encoding in HTTP
        * RFC 4918: HTTP Extensions for WebDAV, obsoletes 2518
        * RFC 5842: Binding Extensions to WebDAV
        * RFC 7238: Permanent Redirect
        * RFC 2295: Transparent Content Negotiation in HTTP
        * RFC 2774: An HTTP Extension Framework
        * RFC 7540: Hypertext Transfer Protocol Version 2 (HTTP/2)
        * RFC 2324: Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0)
        * RFC 7725: An HTTP Status Code to Report Legal Obstacles
        * RFC 8297: An HTTP Status Code for Indicating Hints
        * RFC 8470: Using Early Data in HTTP
    Ú ÚvalueÚintÚphraseÚstrÚreturnc                 C  s   t  | |¡}||_||_|S ©N)r   Ú__new__Ú_value_r   )Úclsr   r   Úobj© r   úb/home/esfera/Documents/content_generation/venv/lib/python3.10/site-packages/httpx/_status_codes.pyr      s   zcodes.__new__c                 C  s
   t | jƒS r   )r	   r   )Úselfr   r   r   Ú__str__#   s   
zcodes.__str__c                 C  s"   zt |ƒjW S  ty   Y dS w )Nr   )r   r   Ú
ValueError©r   r   r   r   r   Úget_reason_phrase&   s
   ÿzcodes.get_reason_phraseÚboolc                 C  ó   d|  ko	dkS   S )zI
        Returns `True` for 1xx status codes, `False` otherwise.
        éd   éÇ   r   r   r   r   r   Úis_informational-   ó   zcodes.is_informationalc                 C  r   )zI
        Returns `True` for 2xx status codes, `False` otherwise.
        éÈ   i+  r   r   r   r   r   Ú
is_success4   r   zcodes.is_successc                 C  r   )zI
        Returns `True` for 3xx status codes, `False` otherwise.
        é,  i�  r   r   r   r   r   Úis_redirect;   r   zcodes.is_redirectc                 C  r   )zI
        Returns `True` for 4xx status codes, `False` otherwise.
        é�  ió  r   r   r   r   r   Úis_client_errorB   r   zcodes.is_client_errorc                 C  r   )zI
        Returns `True` for 5xx status codes, `False` otherwise.
        éô  éW  r   r   r   r   r   Úis_server_errorI   r   zcodes.is_server_errorc                 C  r   )zP
        Returns `True` for 4xx or 5xx status codes, `False` otherwise.
        r!   r$   r   r   r   r   r   Úis_errorP   r   zcodes.is_error)r   ÚContinue)ée   zSwitching Protocols)éf   Ú
Processing)ég   zEarly Hints)r   ÚOK)éÉ   ÚCreated)éÊ   ÚAccepted)éË   zNon-Authoritative Information)éÌ   z
No Content)éÍ   zReset Content)éÎ   zPartial Content)éÏ   zMulti-Status)éÐ   zAlready Reported)éâ   zIM Used)r   zMultiple Choices)i-  zMoved Permanently)i.  ÚFound)i/  z	See Other)i0  zNot Modified)i1  z	Use Proxy)i3  zTemporary Redirect)i4  zPermanent Redirect)r!   zBad Request)i‘  ÚUnauthorized)i’  zPayment Required)i“  Ú	Forbidden)i”  z	Not Found)i•  zMethod Not Allowed)i–  zNot Acceptable)i—  zProxy Authentication Required)i˜  zRequest Timeout)i™  ÚConflict)iš  ÚGone)i›  zLength Required)iœ  zPrecondition Failed)i�  zRequest Entity Too Large)iž  zRequest-URI Too Long)iŸ  zUnsupported Media Type)i   zRequested Range Not Satisfiable)i¡  zExpectation Failed)i¢  zI'm a teapot)i¥  zMisdirected Request)i¦  zUnprocessable Entity)i§  ÚLocked)i¨  zFailed Dependency)i©  z	Too Early)iª  zUpgrade Required)i¬  zPrecondition Required)i­  zToo Many Requests)i¯  zRequest Header Fields Too Large)iÃ  zUnavailable For Legal Reasons)r#   zInternal Server Error)iõ  zNot Implemented)iö  zBad Gateway)i÷  zService Unavailable)iø  zGateway Timeout)iù  zHTTP Version Not Supported)iú  zVariant Also Negotiates)iû  zInsufficient Storage)iü  zLoop Detected)iþ  zNot Extended)iÿ  zNetwork Authentication RequiredN)r   )r   r   r   r	   r
   r   )r
   r	   )r   r   r
   r	   )r   r   r
   r   )LÚ__name__Ú
__module__Ú__qualname__Ú__doc__r   r   Úclassmethodr   r   r   r    r"   r%   r&   ÚCONTINUEÚSWITCHING_PROTOCOLSÚ
PROCESSINGÚEARLY_HINTSr,   ÚCREATEDÚACCEPTEDÚNON_AUTHORITATIVE_INFORMATIONÚ
NO_CONTENTÚRESET_CONTENTÚPARTIAL_CONTENTÚMULTI_STATUSÚALREADY_REPORTEDÚIM_USEDÚMULTIPLE_CHOICESÚMOVED_PERMANENTLYÚFOUNDÚ	SEE_OTHERÚNOT_MODIFIEDÚ	USE_PROXYÚTEMPORARY_REDIRECTÚPERMANENT_REDIRECTÚBAD_REQUESTÚUNAUTHORIZEDÚPAYMENT_REQUIREDÚ	FORBIDDENÚ	NOT_FOUNDÚMETHOD_NOT_ALLOWEDÚNOT_ACCEPTABLEÚPROXY_AUTHENTICATION_REQUIREDÚREQUEST_TIMEOUTÚCONFLICTÚGONEÚLENGTH_REQUIREDÚPRECONDITION_FAILEDÚREQUEST_ENTITY_TOO_LARGEÚREQUEST_URI_TOO_LONGÚUNSUPPORTED_MEDIA_TYPEÚREQUESTED_RANGE_NOT_SATISFIABLEÚEXPECTATION_FAILEDÚIM_A_TEAPOTÚMISDIRECTED_REQUESTÚUNPROCESSABLE_ENTITYÚLOCKEDÚFAILED_DEPENDENCYÚ	TOO_EARLYÚUPGRADE_REQUIREDÚPRECONDITION_REQUIREDÚTOO_MANY_REQUESTSÚREQUEST_HEADER_FIELDS_TOO_LARGEÚUNAVAILABLE_FOR_LEGAL_REASONSÚINTERNAL_SERVER_ERRORÚNOT_IMPLEMENTEDÚBAD_GATEWAYÚSERVICE_UNAVAILABLEÚGATEWAY_TIMEOUTÚHTTP_VERSION_NOT_SUPPORTEDÚVARIANT_ALSO_NEGOTIATESÚINSUFFICIENT_STORAGEÚLOOP_DETECTEDÚNOT_EXTENDEDÚNETWORK_AUTHENTICATION_REQUIREDr   r   r   r   r      s     
N)Ú
__future__r   Úenumr   Ú__all__r   ÚcodeÚsetattrÚ_name_Úlowerr   r   r   r   r   Ú<module>   s     ÿ